Due to Hurricane Ophelia, our Customer Care team is closing early today. You can still email our team and will get back to you within the next two business days.  Thank you.
Neato Support

We're here to help.

  Back

What are the System Requirements for using Botvac Connected with the Neato app?

  1. Internet connection required
    • An Internet connection is required to run the robot in connected mode
    • An Internet connection is required to use the Neato app.
    • Basic internet connection speeds (56kbsp and higher)
  2. Router / Extenders
    • Neato Botvac Connected Series robots ONLY support 2.4GHz Wi-Fi networks.  The Neato app automatically shows you only 2.4GHz wireless networks when you setup up your robot.
  3. Devices Supported
    • Apple Devices
      • Software
        • iOS 8 and newer
      • Hardware
        • Apple iPhone 4 and newer
        • Apple iPad2 and newer
        • Apple iPod Touch (5th Generation)
        • Apple iPad Mini and newer
        • Note: Neato app is not optimized for tablets.
    • Android Devices
      • Software
        • Android 4.0 (Ice Cream Sandwich) and newer
      • Hardware:
        • Supported:
          • xlarge screens (at least 960dp x 720dp)
          • large screens (at least 640dp x 480dp)
          • normal screens (at least 470dp x 320dp)
        • Not Supported:
          • small screens are at least 426dp x 320dp
  4. Network Security
    • WPA and WPA2 using TKIP, PSK, AES/CCMP encryption.
    • WEP EAP (Enterprise Authentication Protocol) are not supported.
  5. Wi-Fi Channels
    • The FCC requires all wireless devices in the US to operate on wireless spectrum channels 1-11.
    • Countries outside of North America can use spectrum channels above channel 11. Please refer to your local regulatory agency to determine what channels are accessible.
    • A future robot software release will support access to channels above 11 to users outside of North America.  Until then, please use channels 1-11.
    • Please check www.NeatoRobotics.com/support for software updates.
Was this article helpful?

  Back