Issue
You cannot get past the step 'Reconnecting to your device'.
Applies to
Topic(s): connection | app | wifi
Robot Model(s): D3 | D4 | D5 | D6 | D7
App Version: Neato App
Note: For the D8 robot and all models above, you need to use the MyNeato app.
Resolution
Close the Neato app completely. Then go to your phone's WiFi settings and make sure that you are properly connected to your home Wifi network.
Open the app and you will see that the robot is now connected.
Cause
The Neato app was disconnected from your WiFi network and then tried to connect again but could not.
If the issue persists, please click on the blue Chat icon for assistance or visit our Customer Care contact page for more options.